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CHAPTER A INTRODUCTION 

A.1. Short description of CAPSOL 

CAPSOL is a thermal building simulation program to calculate multizonal dynamic heat transfer, 
which takes into account heat capacity (CAP-) and solar radiation (-SOL). 
The required input is: 
− Geometric model of the building zones and environment (external obstacles for solar radiation). 
− Thermal and solar properties of walls, wall layers and zones. 
− Climate data (e.g. hourly values of temperatures, global and diffuse solar radiation on a 

horizontal surface) and geographic location. 
− Heat gains from internal heat sources. 
− Comfort requirements (set-point temperatures and ventilation rates). 
− Parameters of heating, cooling, ventilation and sunshade control systems. 
− Calculation period and time step. 
Every time step an energy balance is calculated based on the changing boundary conditions and 
controls.  A solar processor for the direct and diffuse solar radiation is used on the 3D model to get 
accurate solar loads on walls, glazings and internal zones.  Conduction and heat storage in walls are 
calculated one-dimensional.  Infrared radiation and diffuse solar radiation are distributed using view 
factors, automatically calculated from the 3D model. 
The calculation can be executed interactively step by step, showing results filled on the 3D 
geometry or with charts. 
The possible output is: 
− Energy needs for space heating and cooling. 
− Contribution of passive solar gains. 
− Use of building inertia for heat accumulation (e.g. with intermittent heating or cooling). 
− Temperature transgressions and overheating. 
− Response time of heating and cooling on thermal comfort. 
− Detailed analysis of transmission and ventilation heat transfer. 
CAPSOL can be used for optimising the energy performance and thermal comfort, and assessing 
the effects of possible energy conservation measures. 

A.2. Normative references 

− EN 410, Glass in building – Determination of luminous and solar characteristics of glazing. 
− EN 673, Glass in building – Determination of thermal transmittance (U value) – Calculation 

method. 
− ISO 13370, Thermal performance of buildings – Heat transfer via the ground – Calculation 

methods. 
− ISO 13786, Thermal performance of building components – Dynamic thermal characteristics – 

Calculation methods. 
− ISO 13790, Energy performance of buildings – Calculation of energy use for space heating and 

cooling. 
− ISO 13791, Thermal performance of buildings – Calculation of internal temperatures of a room 

in summer without mechanical cooling – General criteria and validation procedures. 
− ISO 13792, Thermal performance of buildings – Calculation of internal temperatures of a room 

in summer without mechanical cooling – Simplified methods. 
− EN 15255, Energy performance of buildings – Sensible room cooling load calculation – General 

criteria and validation procedures. 
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− EN 15265, Thermal performance of buildings – Calculation of energy needs for space heating 
and cooling using dynamic methods – General criteria and validation procedures. 

A.3. System requirements 

− CAPSOL is a 32-bit Windows program. 
− CAPSOL uses OpenGL for hardware accelerated graphics. 

OpenGL uses two system files glu32.dll and opengl32.dll in the Windows system folder. 
− The installed RAM (preferably 1Gb up to the maximum of 2 Gb) determines the available 

calculation power. 
Memory intensive operations may be the view factor calculation, the system solution for a large 
number of system nodes, the storage of intermediate solutions for a combination of a small 
calculation time step with a long calculation period. 
The memory usage can be followed with the Windows Task Manager (Performance tab). 

− A software licence of CAPSOL is protected with a dongle. 

A.4. Hardware key protection 

The software CAPSOL is protected by a hardware key, to prevent illegal use of the software. 
In this way both the client and software developer are better protected for their investment and 
development effort.  It is strongly recommended to take a financial assurance for loss of the key by 
theft or any other incidence. 
 
Before using CAPSOL, the hardware key must be connected and the key driver installed. 
Run from the distribution CD: [CD-drive]:\Sentinel\Driver\Sentinel Protection Installer 7.6.6.exe 
(or a more recent version, which can be downloaded from http://www.safenet-inc.com). 
After installation see 
C:\Program Files\SafeNet Sentinel\Sentinel Protection Installer\7.6.6\English\ReadMe.pdf. 

A.5. Overview of delivered files and file structure 

CAPSOL is installed (when the user accepts the default destination) in the directory 
C:\Program Files\Physibel. 
 
The following directory structure is used: 
…\Physibel\Capsol5 CAPSOL program Capsol.exe, imagelib.dll, 
  RainbowColor.rgb 
 wall type editor WallTypeEdit.exe, Patterns.pat 
 function editor Funcedit.exe 
…\Physibel\Capsol5\Data\Project   all data files related to a project 
 CAPSOL data files *.cps files 
 wall type data files *.cwt files 
 function data files (+ climate data) *.fte, *.fsg, *.fsd files 
 calculated view factors *.vwf files 
 time step solution files *.sol files 
 graphic output *.png files 
 text output *.txt files 
…\Physibel\Materials material databases *.phm files 
 material editor MatEdit.exe, MatEdit.prm, 
  imagelib.dll, Patterns.pat 
…\Physibel\Climates climate files *.fte, *.fsg, *.fsd files 
…\Physibel\Manuals manuals *.pdf files 

http://www.rainbow.com/


CHAPTER B DRAWING THE GEOMETRY 

B.1. Drawing lines 

Two input windows are used to draw lines: 
− The Image window (Edit > Image or program function key F11). 
− The Drawing Vector window (Edit > Drawing Vector or F12). 
 

 

The Image window shows the coordinate axes of the coordinate 
system XYZ as a red (for X), a green (for Y) and a blue (for Z) line. 
The figure at the left shows the Image window for a new project 
(File > New). 
 

 
The Drawing Vector window allows the enter new points, which are positioned with reference to 
the last entered point (i.e. relative coordinates).  The Image window shows a dotted line between the 
last entered point (where the red, green and blue axes are positioned) and the new point.  All 
coordinates are (positive or negative) integer values, expressed in cm.  The spherical coordinates 
(distance, azimuth and elevation) can also be used to enter a new point (distance in cm, azimuth and 
elevation angles in °). 
The figure below shows the Drawing Vector window with the following fields: 
− From [cm]: Absolute coordinates in cm of starting point of current drawing vector (in this 

starting point the red, green and blue coordinate axes are positioned). 
− To (abs.) [cm]: Absolute coordinates in cm of end point of current drawing vector. 
− To (rel.) [cm]: Relative coordinates in cm (with reference to the starting point) of end point of 

current drawing vector. 
− Distance [cm]: Distance in cm of current drawing vector. 
− Azimuth [°]: Horizontal angle from positive X axis to horizontal projection of drawing vector. 
− Elevation [°]: Vertical angle from horizontal projection of drawing vector to drawing vector. 
 

 
 
The following commands are available to define lines: 
− Geometry > Line Start or shortcut key F4: defines the starting point of a line. 

The reference point (crosspoint of the red, green and blue axes) moves to this starting point. 
− Geometry > Draw To or shortcut key F5: defines the end point of a line. 

A line is drawn from the last entered point (“From”) to the end point (“To”), and this new point 
becomes the new reference point (crosspoint of the red, green and blue axes). 
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In this way the consecutive line segments of a polyline can quickly be drawn by defning the 
consecutive vertices (each time with reference to the previous vertex) and pressing F5. 

 

 

In select mode (Image > Select or shortcut key F1) a previously 
defined point can be selected in the Image window by moving 
the mouse cursor over that point. 
A selected point is highlighted in the Image window showing a 
little (colour inverted) square over that point. 
By pressing the left mouse button on a selected point, the 
coordinates of this point are copied as new point in the Drawing 
Vector window. 
 

B.2. Drawing a simple wall 

When the lines of the perimeter of a wall are drawn (as a closed polyline), the wall surface can be 
defined in the following way. 
Select a line of the perimeter (in “select mode” using F1) by clicking the left mouse button on that 
line, so that it becomes a thick blue line. 
Then using the mouse select the end point of a line connected to an end point of the selected line, 
and click the left mouse button on that selected point. 
 

 

Step 1: 
Move the mouse cursor to a line of the closed 
perimeter. 

 

 

Step 2: 
Click the left mouse button to select the line. 
The selected line becomes blue. 
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Step 3: 
Select a point that is the end point of a line 
connected to the selected (blue) line. 

 

 

Step 4: 
The triangle formed by both end points of the 
selected line together with the selected point is 
coloured in pink, and the new line created by 
this triangle (different of the original selected 
line and the other existing line) becomes the new 
selected line. 

 

Step 5: 
Repeat step 3 and 4, starting from the current 
selected (blue) line, which is a diagonal of the 
quadrangular face we are creating. 

 

 

Step 6: 
After clicking the final vertex of the polygonal 
face, a new wall is created (cf. Walls window, as 
in the figure below), and the wall face is 
coloured in light grey in the Image window. 
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Remark to step 4: 
It may happen that no triangle is formed after 
selecting a point opposite to the selected (blue) 
line. 
This is because the selected point is not directly 
connected to an end point of the selected (blue) 
line, although there may be a visible connection 
in the Image window.  In fact this visible 
connection line may consist of several smaller 
line segments (cf. next figure). 

 

 

Two lines (AB and BC) are defined in the 
geometric model, but not the wanted line AC. 
The solution to this problem (in creating the 
pink triangle of step 4) is to define explicitly the 
line AC: 
Move the mouse cursor to point A and define it 
as starting point of a new line (press F4). 
Then move the mouse cursor to point C and 
define it as end point of a new line (press F5). 
Now return to step 4 to fill the triangle. 

 

 

Remark to step 6: 
It may happen that the face remains coloured in 
pink and the blue selection line does not 
disappear, though the entire face is filled. 
This is because one (or more) of the visible 
edges are not present as well defined lines, but is 
(or are) composed of smaller line segments (as 
AB and BC in the previous figure). 
After deleting the pink face (cf. next figure), 
redefine explicitly all wanted contour lines 
(selecting the successive vertices with the mouse 
and pressing F5), and repaint the face. 
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Select face: 
A face can be selected by moving the mouse 
cursor inside the face and clicking the left mouse 
button (in “select” mode, which is active after 
pressing F1). 
A blue dotted pattern shows the selected face. 
The selected face can be deleted using the 
command Geometry > Delete or pressing the 
<Delete> key. 

 

 

Remark to select face: 
A wall face may (unintentionally) overlap 
another face. 
A moiré pattern as in the left figure shows the 
overlapping parts. 
Such overlapping faces must be deleted to have 
a clean unambiguous geometric model (see also 
section B.8). 

B.3. Drawing a wall with window 

To draw a polygonal face with a hole inside, we need to draw a diagonal to be able to fill the face. 
 

Move to one end point of the diagonal using the 
command Geometry > Line Start or using the 
shortcut key F4. 
Then select the second end point using the left 
mouse button, and choose the command 
Geometry > Diagonal or F6. 
The diagonal is drawn in orange. 
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Now the diagonal can be used in drawing the 
triangulation of the face between the outside 
and inside polygon, using the method of the 
previous paragraph. 

 
Then select a connected vertex on one of both 
polygons to proceed the triangulation (as in 
step 4 of section B.2). 

 
Continue the triangulation until the face 
between both polygons is completely filled, and 
a new wall (with reference to this face) is added 
to the Walls window. 
Notice the original diagonal is removed from 
the representation, and the completed 
triangulation is filled in grey. 

 
Sometimes it is also useful to add diagonals in 
filling simple walls (as in the left figure), when 
the wanted wall edges cannot be selected, 
because of other overlapping lines (as e.g. for 
the left edge of the new wall). 
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Now select the diagonal as base line for filling 
the triangulation of the new face. 

 

B.4. Drawing a curved wall 

Using an appropriate triangulation it is possible to draw any curved wall, as in the figure below. 
 

  
 
Important remarks 
− In the system of equations, used in the thermal calculation, each wall surface is represented by 

only one node.  However the total wall area, weight, and the thermal load (e.g. from solar 
radiation) are calculated based on all triangles (with possibly different orientations) of the face 
triangulation.  The total thermal load is then imposed to the single surface node.  In the Image 
window all output refers to the (averaged) values (of solar irradiation, absorbed solar radiation, 
temperature, fluxes or cumulated energy) in the surface node. 

− The area of each triangle of a wall triangulation should be larger than 100 cm2, otherwise this 
triangle is neglected in the view factor calculation (cf. section B.13). 

B.5. Painting the wall types 

The thermal characteristics of the different layers of a wall are defined in a wall type file (with file 
extension .cwt).  Wall type files are created with the Wall Type Editor (cf. Chapter F). 
The wall type files (*.cwt) used in a CAPSOL project must be loaded in the Wall Types window 
(cf. section C.1) via wall type records which refer to the wall type file names (via the field 
“Name”). 
The figure below shows an example with 1 wall type referring to the wall type file  
External Wall.cwt. 
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The current wall type (determined by the active cell, surrounded by bold lines) can be attributed to a 
wall using the paint tool.  Select Image > Paint or the shortcut key F2 (which alters the mouse 
cursor in the Image window from an arrow into a crosshair). 
Select View > Wall Type to activate the option of colouring walls in the Image window using the 
colours of their attributed wall types. 
Click the left mouse button within the wall.  The wall is now painted using the colour of the current 
wall type (see second column in the Wall Types window). 
The figures below show the wall before (left figure) and after (right figure) the mouse click. 
 

  
 
The Walls window is adapted accordingly (column “Wall Type”). 
 

 
 
The painting can be made undone, by selecting Image > Unpaint or Ctrl+F2, and clicking inside the 
wall using the left mouse button. 

B.6. Painting the zones 

Each wall must be painted again to identify the zones at both sides of it. 
Suppose the zones used in the CAPSOL project are defined in the Zones window (cf. section C.2) 
as in the figure below.  The first zone (zone no. 1) must always be the “solar zone”, i.e. the exterior 
with the sun. 
 

 
 
Select View > Zone (to view the zones in the Image window) and choose Image > Paint or F2. 
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Position the grid cursor in the Zones window on a field of the wanted zone (e.g. zone 1, “Exterior”). 
Click with the left mouse button on the wall in the Image window.  The figures below show the 
result in the Image window (the wall colour has changed from grey into blue) and the Walls 
window. 
 

 
 

 
 
Choose Image > Rotate or F3, and drag the mouse in the Image window to rotate the wall until the 
other side of the wall is visible (which is still unpainted, because zone painting only affects only one 
wall side). 
Position the grid cursor in the Zones window on a field of the second zone (“Interior”). 
Now paint the other wall side using this new zone (press F2 and click on the wall). 
 

  
 

 
 
Edit the surface heat transfer coefficients in the Walls window, where needed. 
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Important remark 
Check the position of the zones in the fields “From Zone” and “To Zone” which must be 
compatible to the layer sequence in the wall type file (cf. section F.1): the “from” zone must be at 
side 1 in the wall type editor (i.e. before layer 1), while the “to” zone must be at side 2 (i.e. after the 
last layer).  In the example above, this is OK and nothing has to be done. 
If necessary switch the zones “From Zone” and “To Zone” using the command Walls > Reverse 
Zones or the shortcut key F7 (cf. section C.3). 
The solar zone (always zone 1 in the Zones window; cf. section C.2) must always be in the field 
“From Zone” (never in the field “To Zone”).  That is the reason why the layers of wall types of 
external walls must always be ordered from the outside of the building to the inside (cf. secton F.1). 
(A wall with both sides at the outside is only considered as sun obstacle to other walls, but cannot 
receive solar radiation in the solar processor.) 

B.7. Looking inside a closed zone 

When all walls around a closed (or internal) zone are drawn, all wall types can be painted, as well 
as all zones at the exterior side of the walls.  But painting the internal zone is not possible viewing 
from the outside.  The trick is either to make some walls temporarily invisible from the Walls 
window (or the Wall Types window), or maybe better to make the exterior zone temporarily 
invisible from the Zones window. 
 
The figures below show a simple building painted using the wall types (at the left) and painted 
using the exterior zone (at the right). 
 

  

  
 
Select e.g. the left wall from the Image window (figure below left), and make it invisible in the 
Walls window (by changing the “Show” field from YES into NO; result in figure below right). 
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Now the interior zone can be painted on the interior wall surfaces (after clicking F2). 
A disadvantage of this method is that the interior wall surface of the original invisible wall cannot 
be painted directly.  To that end another wall needs to be made (temporarily) invisible, while the 
first wall needs to be made visible again. 
 

  
 
Another (more elegant) possibility to paint the wall surfaces of the interior zone is to switch the 
visibility status of the exterior zone (making it invisible) to view the walls behind this exterior zone 
(cf. figures below left).  The building can be rotated (press F3 and drag) and all interior wall 
surfaces can be painted (press F2 and click on the wall faces; cf. figures below right). 
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In general, by switching the visibility status of zones, walls and/or wall types, any wall surface can 
be made visible and painted. 

B.8. Definition of zone volumes 

When a zone, defined as the union of all regions at one side of (adjacent) walls, is surrounded 
entirely by these walls, then the volume of this (internal) zone is automatically calculated and 
displayed in the Zones window.  The volume corresponding to half the wall thickness of all 
surrounding walls are subtracted from the geometrical volume derived from the flat wall faces. 
The (smaller) errors at the connection lines between the adjacent walls are not taken into account. 
 

 
 
Remark 
When the zone volume is not reported in the Zones window, though the zone seems to be well 
surrounded by walls in the Image window, this is due to the fact that some of these surrounding 
walls are not uniquely, but doubly defined (which cannot be noticed in the Image window).  Try to 
identify those double walls (via scrolling through the Walls window) and delete them (via selection 
in the Image window and pressing the <Delete> key). 
Reversely, when the zone volume is reported in the Zones window, this means that the surrounded 
walls are uniquely defined. 

B.9. Single selection of a line, diagonal or wall 

In select mode (Image > Select or F1) a line, diagonal or wall can be selected by clicking on it with 
the left mouse button in the Image window.  A selected line or diagonal gets a blue colour (cf. 
section B.2).  A selected wall gets a blue dot pattern (cf. example figures in section B.2 and section 
B.7). 
Sometimes the desired wall is not selected after the left mouse button click.  This is because an 
invisible line behind that wall is selected instead (and line selection has priority over wall selection). 
The following example shows this phenomenon. 
Rotate the little building (with exterior zone made invisible) of section B.7 until the top lines of the 
front and back walls overlap one another (cf. figure below left).  Make the exterior zone visible 
again (by switching the “Show” status to “YES” in the Zones window).  In select mode (F1) click 
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the left mouse button on the right side wall with the mouse cursor in the prolongation of the front 
wall top line (cf. figure below middle).  After the mouse click the right side wall is not selected (as 
would be expected).  Instead the top line of the back wall is selected, which is hidden behind the 
right side wall. 
When the exterior zone is made invisible again, this is made evident by revealing the selected line 
(cf. figure below right). 
 

   
 
The solution to this problem is to move the mouse cursor and click the left mouse button again until 
the desired wall is finally selected.  Since at most one object can be selected at any time (when the 
<Shift> key is not used simultaneously), then there are no hidden selections. 
To assure there are no hidden selections or to unselect a selected line or wall, click with the mouse 
outside of the object. 

B.10. Multiple selection of different lines, diagonals and walls 

In select mode (F1) several lines, diagonals and walls can be selected, as long as the <Shift> key is 
held down.  When a selected item is clicked again (while the <Shift> key is held down), this item is 
deselected. 
Because also invisible lines (and diagonals) can unintentionally be added to the selection, as 
explained in the previous paragraph, the option of multiple selection should be used with caution. 
 
Selected items can be deleted (Geometry > Delete or shortcut key <Delete>) or moved (Geometry > 
Move or shortcut key F8) using the displacement defined in the Drawing Vector window. 

B.11. South direction 

The south direction can be viewed using the command View > South (which acts as a toggle).  It is 
shown using a thin yellow line on a black thicker line, starting from the crosspoint of the red, green 
and blue coordinate axes. 
 

 

By default the south direction coincides with the red axis (= X axis). 
The orientation can be modified using the command Settings > 
South… 
Only the horizontal angle (= azimuth) in XY (= horizon plane) can 
be set. 
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B.12. Viewpoint 

The view of the object in the Image window can be altered by selecting a 
view mode in the Image submenu and mouse dragging.  The active view 
mode (either “Rotate”, “Pan”, “Zoom Window” or “Zoom In”) is checked 
in the Image submenu. 
 

 
− Image > Rotate 

Enters rotate mode.  Mouse dragging or pressing arrow keys (left, right, up, down, with Image 
window active) rotate the object. 

− Image > Pan 
Enters pan mode (only possible when the current view is already zoomed in).  Mouse dragging 
or pressing arrow keys (with Image window active) moves the object parallel to the projection 
plane. 

− Image > Zoom Window 
Enters “zoom window” mode.  This allows to draw a zoom rectangle using the mouse in the 
Image window, which defines the borders of a zoomed view. 
Press the <Esc> key to cancel the current zoom rectangle (before releasing the left mouse 
button). 

− Image > Zoom In 
Enters “zoom in” mode.  A following click using the left mouse button in the Image window 
defines the centre point of the zoomed view.  The zoom factor is 75 %. 

− Image > Zoom Out 
Zooms out using a zoom factor of 133 % (or restores the total zoom, when zoomed out enough). 

− Image > Zoom Total 
Shows total object. 

− Image > Previous View 
Shows the previous zoom view. 

− Image > Save Image… 
Saves current image as PNG file. 
The image resolution is defined in the dialog opened with Settings > Graphic Output Size… 
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B.13. Calculate view factors 

At the end of the geometric input, check the following items: 
In the Zones window: 
− The first zone (= zone no. 1) must always be the solar zone. 
− For each interior zone the volume is shown (which means that all surrounding walls are given 

and there are no double wall definitions). 
− For each interior zone the radiation parameter (column “Rad.”) is set to YES, when infrared 

radiation using view factors should be calculated. 
In the Walls window: 
− Each wall is attributed to a wall type. 

Also walls of the surroundings of the building, that make up the skyline, are preferably linked to 
a separate (dummy) wall type, because this allows to quickly hide or show them in the Image 
window by swapping the “Show” status of this wall type in the Wall Types window. 

− The sequence “from zone” “to zone” must correspond to the layer sequence in the wall type 
definition (cf. section B.6). 

 
View factors are calculated out of the wall triangulation data, and are used in the infrared radiation 
heat transfer between wall surfaces in interior zones and the distribution of diffuse solar radiation to 
internal wall surfaces. 
For the solar zone the view factors to the sky are calculated out of the wall triangulation data.  
These sky view factors estimate the fraction of the open sky compared to the global external 
outlook.  Sky view factors are used to calculate the incident diffuse solar irradiation on external 
walls. 
 
The view factor calculation is based on the triangulations created for the definition of walls (cf. 
sections B.2 up to B.4).  Triangles smaller than 1 dm2 are ignored.  Large triangles (with a side 
larger than 1 m) are recursively split.  The view factor between each pair of elementary triangles 
within the same zone are calculated from the surface normal vectors and the line connecting the 
triangle centres.  The view factor equals 0 if the connection line between both centres is obstructed 
by other wall triangles (visibility check).  The elementary view factors are totalled for each wall 
side (calculating the integral of view factors for all elementary triangles belonging to the same 
wall). 
 
The view factor calculation is started using the command Calc > Calc View Factors. 
 

 

When there are too many triangles bordering a zone, the 
calculation fails and an error message is shown. 
 
Warnings are displayed for each zone having small wall 
triangles, which are ignored (cf. figure at the left). 
After clicking OK, the view factor calculation continues. 
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The view factors are saved in a .vwf file (with same file name as CAPSOL data file). 
This .vwf file is a text file, with the following syntax: 
 
For view factors between wall surfaces (within interior zone): “view=Z Ic Jc V”, with: 
Z = zone number (of  interior zone), 
I = wall number (of the view factor source), 
J = wall number (of the view factor receiver), 
c = letter “a” (for first side of wall) or “b” (for second side of wall), 
V = view factor (between 0.005 and 1; if smaller than 0.005, the view factor is neglected). 
 
For view factors to the sky: “skyv=I V”, with: 
I = wall number (of the view factor source), 
V = view factor to the open sky (between 0 and 1). 
 
A view factor file can be read in CAPSOL using the command Calc > Read View Factors…. 
Reading view factors only succeeds if the geometry has not been modified after the view factor file 
was created (using Calc > Calc View Factors). 
Establishing the view factors (by either Calc > Calc View Factors or Calc > Read View Factors…) 
is necessary before starting the calculation (Calc > Calc Start, cf. section D.3). 



CHAPTER C THERMAL DATA INPUT 

C.1. Wall Types window 

The Wall Types window (activated using Edit > Wall Types) contains all wall types that can be 
attributed to walls (cf. section B.5). 
 

 
 
Per wall type there are the following column fields: 
− Sequence number. 
− Colour value, which can be edited (press <Enter> when this field is active, or double click with 

the left mouse button). 
− Name: file name of wall type file (with file extension .cwt), which must be present in the same 

directory as the CAPSOL data file. 
Press <Enter> (when this field is active) to select the .cwt file in the File Open dialog box. 
The wall type files (containing the wall layers and their thermal properties) can be edited using 
the Wall Type Editor (cf. Chapter F). 

− Show: show (“YES”) or hide (“NO”) in the Image window all walls having this wall type. 
− Thickness in cm (not editable). 
− Weight in kg/m2 (not editable). 
 
The following menu commands are available from the submenu Wall Types (cf. figure above right): 
− Wall Types > Insert 

Insert a new wall type after the current one (cf. figure below left). 
 

 
− Wall Types > Delete 

Delete the current wall type. 
This command is disabled if the current wall type is attributed to any wall. 
In that case first unpaint the walls in question (using Ctrl+F2) or paint these walls using a 
different wall type. 

− Wall Types > Move 
Highlight the current wall type (cf. figure above right), which then can be moved up or down 
using the arrow keys or a mouse click on a different row. 

− Wall Types > Stop Move 
Stop “move” mode. 
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− Wall Types > Show All 
Set “show = YES” for all wall types. 

− Wall Types > Show Only Current 
Set “show = YES” for the current wall type, and “show = NO” for all other wall types. 

− Wall Types > Save Values… 
Save the properties of all wall types in a text file. 

C.2. Zones window 

The Zones window (activated with Edit > Zones) contains all zones that can be attributed to wall 
sides (cf. section B.6). 
The first zone in the list of zones must be the solar zone (if solar radiation is involved). 
 

 
 
Per zone there are the following column fields: 
− Sequence number. 
− Colour value, which can be edited (press <Enter> when this field is active, or double click with 

the left mouse button). 
− Name. 
− Show: show (“YES”) or hide (“NO”) the current zone in the Image window. 
− Volume (not editable): volume in m3 of interior zone (entirely surrounded by walls, but without 

double redundant wall definitions, cf. section B.8). 
The volume corresponding to half the wall thickness of all surrounding walls are subtracted from 
the geometrical volume derived from the flat wall face positions.  The (smaller) errors at the line 
connections between the adjacent walls are neglected. 

− Material density ρ in kg/m3. 
− Weight in kg (not editable). 
− Specific heat c in J/(kg.K). 
− Radiation: YES or NO (only enabled for interior zones). 

If “YES”, infrared radiation using view factors is considered in the current (interior) zone. 
If “NO” (or blank field for exterior zone), the heat transfer between the current zone and the 
surrounding walls is convective (using global surface heat transfer coefficients, as defined in the 
Walls window). 

− Fixed temperature: YES or NO (only enabled for interior zones). 
− Temperature: fixed value (in °C) or reference to temperature function (T01 up to T99, cf. section 

C.9). 
− Power: internal power released in zone convection node. 

Fixed value (in W) or reference to power function (P01 up to P99, cf. section C.9). 
− Flux: imposed on all wall surfaces bordering the current zone. 

Fixed value (in W/m2) or reference to infrared flux function (I01 or I99, cf. section C.9). 
 
The following menu commands are available from the submenu Zones: 
− Zones > Insert: insert a new zone after the current one. 
− Zones > Delete: delete the current zone. 

This command is disabled if the current zone is attributed to any wall side. 
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In that case first unpaint the wall sides in question (using Ctrl+F2) or paint these wall sides using 
a different zone. 

− Zones > Move: highlight the current zone, which then can be moved up or down using the arrow 
keys or a mouse click on a different zone. 

− Zones > Stop Move: stop “move” mode. 
− Zones > Show All: set “show = YES” for all zones. 
− Zones > Show Only Current: set “show = YES” for the current zone, and “show = NO” for all 

other zones. 
− Zones > Save Values…: save the properties of all zones in a text file. 

C.3. Walls window 

The walls in the Walls window (activated using Edit > Walls) are created when drawing the 
geometry (cf. section B.2). 
 

 
 
The outline of the current wall in the Walls window is highlighted in the Image window (cf. figure 
below left). 
 

  
 
Per wall there are the following fields: 
− Sequence number. 
− Show: show (“YES”) or hide (“NO”) the current wall in the Image window. 
− Wall type: set by painting the wall type in the Image window (cf. section B.5). 
− From zone (= zone 1): zone at one side of the wall, before the first layer of the wall type. 

The sequence of the wall type layers is visible in the Wall Type Editor (cf. section F.1). 
A zone is attributed to a wall side by painting in the Image window (cf. section B.6). 

− To zone (= zone 2): zone at other side of the wall, after the last layer of the wall type. 
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− hg1 [W/(m2.K)]: global surface heat transfer coefficient at first wall side (adjacent to zone 1).  
This field is only editable if zone 1 is an exterior zone (volume field is empty in Zones window) 
or an interior zone without infrared radiation (“Rad.” = NO in Zones window). 

− hc1 [W/(m2.K)]: convective heat transfer coefficient at first wall side (adjacent to zone 1). 
This field is only editable if zone 1 is an interior zone with infrared radiation (“Rad.” = YES in 
Zones window). 

− hg2 [W/(m2.K)]: global surface heat transfer coefficient at second wall side (adjacent to zone 2).  
This field is only editable if zone 2 is an exterior zone (volume field is empty in Zones window) 
or an interior zone without infrared radiation (“Rad.” = NO in Zones window). 

− hc2 [W/(m2.K)]: convective heat transfer coefficient at second wall side (adjacent to zone 2). 
This field is only editable if zone 2 is an interior zone with infrared radiation (“Rad.” = YES in 
Zones window). 

− Area [m2]: area of wall triangulation (cf. section B.2). 
− Weight [kg]: product of weight per unit of area of wall type (in Wall Types window) and area. 
 
When a wall is lying between a solar zone (which must be the first zone in the Zones window) and 
another (internal) zone, then the solar zone must be situated in the field “From Zone”.  The layers in 
a wall type of an external wall are ordered from the outside of the building toward to the inside (cf. 
section B.6 and section F.1). 
 
The following menu commands are available from the submenu Walls (cf. figure above right): 
− Walls > Reverse Zones (or shortcut key F7): switch zone 1 (“From Zone”) and zone 2 (“To 

zone”), so that both zones at either sides of the wall are in line with the layer sequence of the 
wall type (cf. section B.6). 

− Walls > Global for Zone: make the current property (hg1, hc1, hg2 or hc2) global to all wall 
sides in the same zone. 

− Walls > Show All: set “show = YES” for all walls. 
− Walls > Save Values…: save the properties of all walls in a text file. 

C.4. Zone Ventilation window 

The Zone Ventilation window (activated using Edit > Zone Ventilation, cf. figure below left) 
contains all (natural and mechanical) ventilation flows to interior zones (having a defined volume in 
the Zones window) with unknown temperature.  Ventilation flows to zones with fixed temperature 
must not be defined, because they have no influence on the system of equations. 
During the calculation the ventilation balance for every zone (with unknown temperature) is 
checked: the total incoming ventilation flow should not be lower than the total outgoing ventilation 
flow (to zones with unknown temperature).  The possible positive difference between the total 
incoming and total outgoing ventilation flows is supposed to leave to a zone with known 
temperature (which is neutral to the system). 
For every ventilation flow in the Zone Ventilation window both zones (source and destination) 
should have equal material density and specific heat (as defined in the Zones window).  This 
requirement is checked at the start of the calculation. 
 

 

 
Per ventilation flow there are the following fields: 
− Sequence number. 
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− “From”: zone number of ventilation source (exterior or interior zone). 
− “To”: zone number of ventilation destination (which must be an interior zone with unknown 

temperature). 
− “Rate [m3/h]”: ventilation flow rate in m3/h or reference to ventilation function (V01 up to V99, 

cf. section C.9). 
− “Rate [h]” (not editable): number of volume changes (of destination zone) per hour. 
− Control: if blank, this ventilation flow is always applied. 

If a control sequence number (of a ventilation control, cf. section C.7) is entered, this ventilation 
flow is only applied when the referred ventilation control is set (i.e. when the condition of this 
ventilation control is true). 

 
The following menu commands are available from the submenu Ventilation (cf. figure above right): 
− Ventilation > Insert: insert a new ventilation flow after the current one. 
− Ventilation > Delete: delete the current ventilation flow. 
− Ventilation > Filter From (toggle): show only the ventilation flows with source zone equal to the 

source zone of the current ventilation flow. 
− Ventilation > Filter To (toggle): show only the ventilation flows with destination zone equal to 

the destination zone of the current ventilation flow. 

C.5. Nodes window 

The Nodes window (activated using Edit > Nodes) contains the nodes in the system of thermal 
equations that are used as control points referred to in the Conditions window (cf. section C.6) or 
Controls window (cf. section C.7). 
 

 
 
There are two types of nodes: 
− Zone node: convection node (with air temperature or fluidum temperature) of a zone, which is 

connected to the nodes of the surrounding wall surfaces via the convective heat transfer 
coefficients. 

− Wall node: wall surface node or internal wall node in the interface between two wall layers. 
 
Per node in the Nodes window there are the following fields: 
− Sequence number. 
− Name. 
− Type: ZONE or WALL. 
− Object number: zone number (if type = ZONE) or wall number (if type = WALL). 

The next two fields show the colour and name of this zone or wall (copied from the Zones 
window or Walls window). 

− Layer interface (only if type = WALL): toggle button (press <Enter> to pass through the 
successive wall layer interfaces). 

 
A new node can be inserted using Edit > Insert. 
An existing node can be deleted using Edit > Delete. 
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C.6. Conditions window 

The Conditions window (activated using Edit > Conditions) contains the conditions imposed by the 
controls in the Controls window. 
A condition is a logical expression which compares the value of a property to a target value. 
The condition is evaluated at each time step during the calculation.  The result (true or false) is used 
to trigger a control. 
 

 
 
There are two types of conditions: 
− Basic condition (type = BASIC): which compares the value of a property (e.g. temperature or 

solar irradiation) in a node (defined in the Nodes window) to a target value (or target function). 
− Composite condition (type = COMPOSITE): which performs a logical operation (“AND”, “OR”, 

“NOT”) on one or two basic conditions or control results (defined in the Controls window). 
 
Per condition there are the following fields: 
− Sequence number. 
− Name. 
− Type: BASIC or COMPOSITE. 
If type = BASIC: 
− Property: TEMP (node temperature), OPTEMP (operative temperature of a zone, which is the 

mean of the air temperature and the radiation temperature of the surrounding wall surfaces), 
TEMPDIFF (temperature difference) or SOLRAD (total solar irradiation on an external wall 
surface in W/m2). 

− Sensor node: node number in Nodes window, where the property is evaluated. 
− Reference node (only if property = TEMPDIFF): node number of second node (which 

temperature is the subtrahend of the temperature difference) in Nodes window. 
− Operand: < (less than) or > (greater than). 
− Target: numerical value or (if property = TEMP, OPTEMP or TEMPDIFF) reference to 

temperature function (T01 up to T99). 
− Margin: upward and downward sensitivity with reference to the target value. 

For operand <: 
if sensor value < target value – margin, then condition result = true; 
else if sensor value > target value + margin, then condition result = false; 
else condition result remains unchanged (same result as for previous time step). 
For operand >: 
if sensor value > target value + margin, then condition result = true; 
else if sensor value < target value – margin, then condition result = false; 
else condition result remains unchanged (same result as for previous time step). 

If type = COMPOSITE: 
− Property: CONDIT (condition) or CTRL (control). 
− Number: condition sequence number in Conditions window (if property = CONDIT) or 

control sequence number in Controls window (if property = CTRL). 
− Operand: AND, OR (inclusive disjunction) or NOT. 
For both types (BASIC and COMPOSITE): 

Manual CAPSOL v5.0w 25 



− Result: condition result at current time step (TRUE or FALSE, only displayed during a 
calculation). 
If result = INVALID, then there is an error in one or more condition parameters. 

 
A new condition can be inserted using Edit > Insert. 
An existing condition can be deleted using Edit > Delete. 

C.7. Controls window 

The Controls window (activated using Edit > Controls) contains the controls of the system. 
 

 
 
There are three types of controls: 
− Power (heating when positive, or cooling when negative) released in a node (defined in the 

Nodes window) with an exponential course: 
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with: 
Pt = power at time t (t = 0 when starting the power release), 
Pmax = maximum power, 
τ = time constant (time required to release 63.2 % of the maximum power). 
If the power is switched off, there is an exponential decay (using the same time constant). 

− Extra ventilation flow(s) (defined in the Ventilation window with parameter “Control” = control 
sequence number, cf. section C.4). 
These extra ventilation flows are activated when the result of the corresponding condition is true. 

− Sunshade control applied to a wall, implemented by using a different wall type with modified 
thermal properties for the wall layers (solar reflection, transmission, absorption, infrared 
emissivity, thermal conductivity). 
The original wall type and the new wall type must generate the same number of system nodes 
with unchanged thermal capacities (due to the law of conservation of energy).  Both wall types 
must have the same number of layers, and per layer the same layer type (“normal” or “gas”),  
thickness, density (ρ) and specific heat (c). 

 
Per control there are the following fields: 
− Sequence number. 
− Name. 
− Condition number (in the Conditions window), which when true activates the control (control 

result = ON), and when false deactivates the control (control result = OFF). 
− Action: HEATING, COOLING, VENTIL or SUNSHADE. 
If action = HEATING or COOLING (i.e. power control): 
− Node: node number in Nodes window, in which the control power is released. 
− Pmax [W]: maximum power. 
− τ [min]: time constant of exponential power release in minutes. 
If action = SUNSHADE: 
− Wall: wall number in Walls window, on which the sunshade control is applied. 
− Wall type (not editable): colour and name of (original) wall type of wall. 
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− New wall type: wall type number in Wall Types window of new wall type (compatible to the 
original one) adopted to the wall as sunshade. 

− Next two fields (not editable): colour and name of new wall type. 
If action = VENTIL: no other fields must be defined in the Controls window.  The corresponding 
ventilation flows are defined in the Ventilation window (cf. section C.4). 
For all controls (HEATING, COOLING, VENTIL or SUNSHADE): 
− Time On [min]: minimum time duration in minutes that the control remains active once switched 

on. 
− Time Off [min]: minimum time duration in minutes that the control remains deactivated once 

switched off. 
− Result: control status at current time step (ON or OFF, only displayed during a calculation). 
 
A new control can be inserted using Edit > Insert. 
An existing control can be deleted using Edit > Delete. 

C.8. Solar data 

The command Edit > Solar Data… opens the Solar Data dialog box (cf. figure below). 
 
The solar zone must be the first zone in the Zones window. 
The solar radiation must be defined by the function references G01 (global solar radiation on a 
horizontal face) and D01 (diffuse solar radiation on a horizontal face) in the Functions window. 
 

 
 
The following parameters are defined: 
− Latitude: geographical latitude (positive to the north). 

For Uccle (Brussels): 50.78°N. 
− Longitude: geographical longitude (from the meridian of Greenwich, positive to the east). 

For Uccle (Brussels): 4.37°E. 
− Time zone: offset from UTC (Coordinated Universal Time), positive to the east. 

For Uccle (Brussels): 1 h (winter time) or 2 h (summer time). 
− Ground reflection factor: (diffuse) reflection factor of building surroundings (supposed as an 

infinite horizontal face without obstructions; cf. section D.5). 
Normal value: 0.2.  Very reflective ground (e.g. snow): 0.8 to 0.9. 

C.9. Functions window 

The Functions window (activated using Edit > Functions) contains function references used in 
other windows. 
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All functions are time functions. 
There are several types of functions: 
− Internal functions (type STEP0, STEP1, STEP2, SINE and SINPOS), which are built-in program 

functions (cf. figures below). 
− External functions (type FILE), defined in external files (cf. Chapter G). 

The file extension depends on the function variable, identified by the first letter of the function 
reference: 
− .fte: temperature function [°C] with function reference T## (with # a digit). 
− .ffh: power function [W] with function reference P##. 
− .fir: infrared radiation function [W/m2] with function reference I##. 
− .fsg: global solar radiation on a horizontal face [W/m2] with function reference G01. 
− .fsd: diffuse solar radiation on a horizontal face [W/m2] with function reference D01. 
− .fvr: ventilation flow function [m3/h] with function reference V##. 

 
Per function there are the following fields in the Function window: 
− Sequence number. 
− Function reference: T##, P##, I##, G01, D01 or V##, with ## = 01 up to 99. 
− Function type: toggle with values FILE, STEP0, STEP1, STEP2, SINE and SINPOS. 
− File name (if type = FILE) of file selected from File Open dialog box, in the same directory as 

the CAPSOL data file (because only the file name of the function file, and not its directory, is 
stored in this CAPSOL data file). 

− Parameters 1 to 6: meaning dependent on the function type (cf. below). 
 
The current function can be visualised using the menu command Chart > Function in the Chart 
window (cf. section E.2). 
 
A file function (type = FILE) can be translated (i.e. shifted in time) using a time offset, expressed in 
minutes, via parameter 1 (column  “Prm. 1”) in the Functions window. 
This is useful to align the climate functions (temperature, global and diffuse solar radiation on a 
horizontal face) with e.g. the time of sunrise of sunset displayed in the status bar from the 
calculation start or end time in the Time window (cf. section D.1). 
 
The figures below show the meaning of the different parameters P1 up to P6 (in the columns  
“Prm. 1” up to “Prm. 6” in the Functions window) for the types STEP0, STEP1, STEP2, SINE and 
SINPOS. 
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A new function can be inserted using Edit > Insert. 
A function (if not referred to in another window) can be deleted using Edit > Delete. 
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CHAPTER D CALCULATION 

D.1. Time window 

The Time window (activated using Edit > Time, cf. figure below left) contains the time data for the 
dynamic calculation: 
− Start time. 
− Calculation time step. 
− End time. 
− Current time (once the calculation is started). 
− Time interval (once the calculation is started). 
 
When the current input cell (surrounded by thick lines) is on the start time, end time or current time, 
the status bar contains the times of sunrise and sunset (cf. figure below right). 
If the sun is visible above the horizon, also the solar azimuth (negative at east, 0° at south, positive 
at west) and the solar elevation is given. 
 

 

 
 

 

 
The absolute times (start, end and current time) in the Time window are standard times. 
The relation between standard times and mean solar times depend on the longitude and time zone, 
defined in the Solar Data dialog box. 
For the absolute times the column fields are: 
− Year: number of years since the start time (start year = 0). 
− Month: 1 (for January) up to 12 (for December). 
− Day: from 1 up to 31. 
− Hour (h): from 0 up to 23. 
− Minute (min): from 0 up to 59. 
− Second (s): from 0 up to 59. 
 
For the relative times (time step and interval) 1 month corresponds to 30 days. 

D.2. Calculation parameters 

The Calculation Parameters dialog box is opened using Settings > Calculation Parameters…. 
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There are four calculation parameters: 
− Minimum number of sublayers per wall layer. 
− Maximum thickness of wall sublayer. 
− Minimum thermal resistance of wall sublayer. 
− Black radiation heat transfer coefficient. 
 
Each wall material layer (type NORMAL in wall type editor; cf. section F.2) is subdivided in a 
number of sublayers of equal thickness (and having the same thermal properties as the layer). 
The number of sublayers must be at least the value given by the first calculation parameter. 
However if the thickness of the sublayers is still greater than the value given by the second 
calculation parameter, then the number of sublayers is sufficiently increased. 
A gas layer (type “GAS” in the wall type file; cf. section F.3) is not subdivided into sublayers. 
Within each wall the system nodes are located in the interfaces between the successive sublayers. 
If the number of sublayers is increased, the number of system nodes also grows, and the quality of 
the dynamic calculation improves, but the calculation time prolongs. 
 
For the calculation stability (expressed by the Fourier number of the dynamic system) the thermal 
resistance of each wall sublayer should be large enough. 
If it is smaller than the value of the third calculation parameter, it is replaced by this parameter in 
the system setup to make the system more stable. 
 
The radiation within the zones is linear with a constant black radiation heat transfer coefficient (hrb), 
given as fourth calculation parameter.  The value is based on the estimated mean temperature (θm in 
°C) over all zones with radiation:  with σ = 5.67 *1034 Th ⋅⋅= σ mrb

15.273+

-8 W/(m2.K4) (Stefan-

Boltzmann constant) and = mmT θ . 

D.3. Start calculation 

 

After establishing the view factors between all wall surfaces (cf. 
section B.13), the calculation is started using the menu command 
Calc > Start Calc (to get steady state start values) or Calc > Read 
Step Solution… (to read a previous saved solution file). 

 
The current CAPSOL data are first saved in a CAPSOL data file. 
The system of nodes is set up.  Each wall is considered as a linear list of nodes, which number 
depends on the layers in the wall type (cf. section F.1) and the sublayer calculation parameters (cf. 
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section D.2).  For each wall surface adjacent to a zone with radiation, a black radiation node is 
added.  For each zone with unknown temperature a zone convection node is added. 
The thermal system is set up as a system of linear equations with minimised bandwidth and with 
coefficients that may modify from one time step to the next time step. 
Memory space is allocated for the system and for the solutions (node temperatures) for all time 
steps in the time domain, so that it becomes possible during a calculation to rewind to any previous 
calculated time step, review the solution at that time step and possibly adapt the thermal properties. 
 
The start calculation command (Calc > Start Calc) does the memory allocation and system setup 
(as explained above),  then calculates a steady state solution (ignoring the thermal capacities) for the 
first time step, shows the wall surface temperatures in the Image window, and waits for the next 
user command. 
 
The read step solution command (Calc > Read Step Solution…) does the memory allocation and 
system setup (as explained above), then initialises the node temperatures from a solution file (with 
extension .sol), which must have the same number of nodes as the current system.  If successful, the 
wall surface temperatures are shown in the Image window, and the program waits for the next user 
command. 
 
After a successful Calc > Start Calc or Calc > Read Step Solution… the Time window is updated 
(cf. figure below left): 
− Editing of the start time, time step and end time is disabled (until the command Calc > Close 

Calc is executed). 
− The current (last calculated) time step is shown. 
− The time interval can be edited (used by Calc > Next Interval or Output > Next Interval). 
 

 

 
 
New thermal properties can be entered in the Walls window (hg1, hc1, hg2, hc2), Zones window 
(temperature, power, flux) and Zone Ventilaton window, which will be used for the next time steps. 
The other input fields in these input windows are disabled, because they would generate a different 
system of equations.  The editable input fields only change the coefficients of the system of 
equations. 
New wall types for any wall, that are compatible with the original ones, as for a sunshade control 
(cf. section C.7), can be set for the next time steps by repainting the wall in the Image window (cf. 
section B.5). 
 
Other commands in the Calc submenu (cf. figure above right) are enabled to continue the dynamic 
calculation. 

D.4. Dynamic calculation steps 

The command Calc > Next Step calculates one step ahead from the current time step. 
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The command Calc > Next Interval calculates all steps for the next time interval (as defined in the 
Time window). 
The command Calc > Run Calc calculates all remaining time steps until the calculation end time is 
reached. 
The current time in the Time window is adapted continuously after the calculation of each time 
step. 
 
It is possible to rewind to a previous calculated time step using the 
commands of the Output submenu. 

 
Enter the time of the previous time step as current time in the Time window. 
Then choose the command Output > Current Time to load the solution for that time step.  All input 
from the input windows (Walls window, Zones window and Zone Ventilation window) is now 
blocked, because we are viewing previous calculated results in the Image window. 
The command Output > Next Step loads the solution of the next time step (up to the last calculated 
time step). 
The command Output > Next Interval loads the solution of the time step at the next time interval 
(up to the last calculated time step). 
In this way the solutions for every time step of the complete time range can be reviewed (see also 
section E.1). 
 
At every time step the node temperatures can be saved into a step solution file (with extension .sol), 
using the command Calc > Save Step Solution….  The suggested file name in the File Open dialog 
includes the CAPSOL data file name and the current time. 
 
It is possible to restart the calculation from any previous calculated time step with modified input 
properties.  Use the command Output > Current Time to go back to a previous time step (cf. above).  
Then choose Calc > Edit BCs.  The solutions of all following time steps are cleared from memory, 
so that this time step becomes the last calculated time step.  As a result new thermal properties can 
now be entered in the Walls window (hg1, hc1, hg2, hc2), Zones window (temperature, power, 
flux) and Zone Ventilaton window. 
New wall types for any wall, that are compatible with the original ones, as for a sunshade control 
(cf. section C.7), can be painted in the Image window (cf. section B.5). 
From the current time step the calculation can then again be continued using the commands Calc > 
Next Step, Calc > Next Interval and Calc > Run Calc. 
 
The command Calc > Close Calc stops the calculation process and frees all calculation memory, 
except the view factors.  (The view factors are freed from memory when the geometry is modified, 
or the CAPSOL file is closed.) 

D.5. Solar processor 

Each calculation time step the solar load must be determined. 
 
The position of the sun is calculated out of the time of the current time step (day of year, clock 
time) and the geographical location (latitude, longitude, time zone).  The position of the sun is 
located by two angular measures: azimuth (horizontal clockwise angle from the south to the sun) 
and elevation (vertical angle from the horizon to the sun).  The azimuth of the sun at a fixed clock 
time may differ for different days of the year due to the irregular movement of the sun (defined by 
the equation of time).  This means e.g. that the azimuth at 12 a.m. solar mean time fluctuates around 
0° (= south). 
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For the current time step the actual global solar radiation and diffuse solar radiation (in W/m2) on a 
horizontal surface are derived from the corresponding climate data files (function references G01 
and D01).  Usually these climate files contain hourly values.  The current values are derived 
through linear interpolation from the adjacent hourly values.  For the first and last daylight hour of 
the day, the (estimated) times of sunrise and sunset are used for interpolation. 
 
For each external wall between the solar zone and an internal zone the solar irradiation is 
calculated, which is composed of a direct, a diffuse and a ground reflected component. 
 
For the direct solar irradiation the wall triangles (from the input geometry) are fragmented in 
smaller parts which receive each maximum 10 W (possible obstructions to the sun not taken into 
account).  A visibility test (for a ray between the centre of this wall part and the sun, and 
considering possible shading by other walls) decides whether this solar power must be added to the 
wall external surface node or not. 
 
For the same external wall (between the solar zone and an internal zone) the diffuse solar irradiation 
in the free field (without considering the surroundings) is calculated using the anisotropic diffuse 
model developed by Tariq Muneer, which takes into account the orientation, slope, shaded or sunlit 
condition, overcast and non-overcast condition. 
The diffuse solar irradiation in the free field is reduced by the sky visibility factor, which is the ratio 
of the really open sky to the global sky dome (thus including the surroundings).  The sky visiblity is 
calculated in advance (as part of the command Calc > View Factors) using a high number of 
random rays in all directons from the wall surface to the sky, and counting the fraction which is not 
obstructed by other walls. 
 
The reflected irradiation of the ground to the external wall is calculated using the isotropic diffuse 
model (i.e. irradiation proportional to the square of the sine of half the wall tilt), the global solar 
radiation on a horizontal surface and the ground reflection factor (calculation parameter defined in 
Settings > Calculation Parameters…).  The ground reflected radiation on a vertical surface is half 
the ground reflected radiation on a horizontal downward surface.  The ground reflected radiation on 
a horizontal upward surface equals zero. 
 
What happens with the solar irradiation on the external wall ? 
The direct solar irradiation is reflected based on the angle of incidence (if defined in the wall type 
editor, cf. section F.5). 
The diffuse and ground reflected solar irradiation is reflected based on the global diffuse reflection 
factor (which is calculated from the angular reflection factors, by averaging the angular reflection 
factors over all angles of incidence, randomly distributed over a sphere). 
All this reflected radiation from the external wall back to the solar zone is further ignored. 
 
For a transparent wall the transmitted radiation from the direct solar irradiation is projected along 
the solar beam direction inside the adjacent internal zone onto the first encountered wall. 
The transmitted radiation from the diffuse and ground reflected irradiation is emitted from the 
internal side of the wall to the interior using ideal diffuse radiation (according to Lambert’s cosine 
law). This means that this transmitted radiation is distributed to the other surfaces of the internal 
zone proportional to the view factors from the original wall to the other walls of the internal zone. 
All reflected radiation within an internal zone is also spread diffusely. 
The transmitted and reflected radiation are recursively further distributed using diffuse emission 
until the remaining radiation is small enough (< 0.01 W). 
 
For a non transparent wall the total absorbed solar radiation is absorbed by the wall surface node. 
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For a transparent wall Edwards’ embedding technique is used to distribute the absorbed solar 
radiation over the successive layers of this wall. 
 
Finally all solar irradiation is translated into imposed powers on system nodes. 

D.6. Dynamic calculation principles 

For every new calculation time step the boundary conditions (climate data,  solar loads, ventilation, 
internal gains due to occupants, equipment and lights) are updated and imposed to the right nodes. 
Then the controls (heating, cooling, extra ventilation, sunshades) are set or cleared based on the 
condition results applied on the calculation solution for the previous time step. 
 
The equations of the updated system are set up based on the Cranck-Nicolson method applied for 
every node: 
heat flows at current time step + heat flows at previous time step = 2 x heat capacity change. 
 
The obtained linear system of equations is then solved. 
The system solution runs faster if the wall heat transfer coefficients (hg1, hc1, hg2, hc2 in the Walls 
window) and zone ventilation flows (in the Zone Ventilaton window) are not modified compared to 
the previous time step.  These parameters require new coefficients in the system matrix, while the 
other parameters (imposed temperatures and powers) only change the constant terms of the right-
hand side of the system. 
 
Finally the solution and system parameters for the current time step are saved in memory to be able 
to rewind to these solutions from other time steps (using the commands of the Output submenu, cf. 
section D.4). 
 
A calculation including multiple time steps (Calc > Next Interval, Calc > Run Calc) can be 
interrupted at any time by pressing the <Esc>-key.  The solution is shown for the last finalised time 
step. 



CHAPTER E OUTPUT 

E.1. View commands 

It is possible to load the results of each calculated time step using the commands of the Output 
submenu (cf. section D.4). 
 
Different output quantities can be viewed in the Image window using the commands in the View 
submenu (cf. figure below left).  The wall surfaces are coloured using these quantities (e.g. as in 
figure below right).  The colour scale can be modified with the commands Settings > Temperature 
Range…, Settings > Flux Range…, Settings > Power Range…, Settings > Energy Range… or 
Settings > Ventilation Flow Range…. 
In select mode (Image > Select or shortcut key F1) the quantity value on the wall surface under the 
mouse point is displayed in the program status bar (at the bottom), when the mouse is moved. 
 

  
 
The different view options are: 
− View > Wall Type: wall type colours as defined in Wall Types window (cf. section B.5). 
− View > Zone: zone colours as defined in Zones window (cf. section B.6). 
− View > Solar Irradiance: sum of direct and diffuse (including ground reflected) incoming solar 

radiation (in W/m2) on external wall surfaces touching the solar zone. 
− View > Absorbed Solar Radiation (in W/m2) at wall surfaces. 
− View > Wall Surface Temperature (in °C). 
− View > Zone Temperature: air (or fluidum) temperature (in °C) in zone convection node. 
− View > Operative Temperature: mean value (in °C) of air temperature and radiation temperature 

(area weighted average of all surrounding wall surface temperatures). 
− View > Conduction Heat Flux: heat flux (in W/m2) at the wall surface by conduction (positive 

when leaving the wall flowing into the adjacent zone), calculated from the node temperatures 
and thermal resistance of the sublayer touching this wall surface. 
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− View > Convection Heat Flux: heat flux (in W/m2) leaving the wall surface by convection (if 
adjacent zone has separate radiation and convection) or by global surface heat transfer (if 
adjacent zone has no separate radiation and convection). 

− View > Radiation Heat Flux: heat flux (in W/m2) leaving the wall surface by radiation (if 
adjacent zone has separate radiation and convection). 

− View > Conductive Power: heat power (in W) into adjacent zone by conduction from all walls 
touching this zone. 

− View > Convective Power: heat power (in W) into adjacent zone by convection (or global 
surface heat transfer) from all walls touching this zone. 

− View > Radiative Power: heat power (in W) into adjacent zone by radiation from all wall 
surfaces touching this zone. 

− View > Ventilation Power: heat power (in W) into adjacent zone by ventilation. 
− View > Absorbed Solar Power: heat power (in W) by solar absorption at all wall surfaces 

touching adjacent zone. 
− View > Conductive Energy: total energy (in kWh) into adjacent zone by conduction from all 

walls touching this zone, during last time interval (as defined in Time window). 
− View > Convective Energy: total energy (in kWh) into adjacent zone by convection (or global 

surface heat transfer) from all walls touching this zone, during last time interval (as defined in 
Time window). 

− View > Radiative Energy: total energy (in kWh) into adjacent zone by radiation from all wall 
surfaces touching this zone, during last time interval (as defined in Time window). 

− View > Ventilation Energy: total energy (in kWh) into adjacent zone by ventilation during last 
time interval (as defined in Time window). 

− View > Absorbed Solar Energy: total energy (in kWh) received by solar absorption at all wall 
surfaces touching adjacent zone, during last time interval (as defined in Time window). 

− View > South: south direction (cf. section B.11). 
 
The image in the Image window can be saved in a PNG file using the command Image > Save 
Image….  The image in this file also contains a scale legend at the right side (cf. figure above right). 
The picture resolution (width and height in pixels) and font size of legend characters can be 
modified with the command Settings > Graphic Output Size… (cf. figure below). 
 

 

E.2. Chart window 

A chart shows an output quantity (e.g. temperature, flux, power) as a function of time in the Chart 
window. 
A chart (e.g. figure below right) is activated from the Chart submenu (cf. figure below left). 
The enabled commands depend on the context of the active window and cell. 
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The possible commands creating a chart, are: 
− Chart > Function (only enabled from the Functions window): shows the current function 

(determined by the position of the input cell in the Functions window). 
− Chart > Solar Irradiance (only enabled from the Walls window): shows the solar irradiance (in 

W/m2) on the current wall surface (determined by the position of the input cell in the Walls 
window, i.e. wall side 1 for column “From Zone”, “hg1”, “hc1”, and wall side 2 for column “To 
Zone”, “hg2”, “hc2”). 

− Chart > Absorbed Solar Radiation (only enabled from the Walls window): shows the absorbed 
solar radiation (in W/m2) at the current wall surface (determined by the position of the input cell 
in the Walls window, i.e. wall side 1 for column “From Zone”, “hg1”, “hc1”, and wall side 2 for 
column “To Zone”, “hg2”, “hc2”). 
For an opaque wall surface this absorbed solar radiation multiplied by the wall surface is entirely 
released in the wall surface node. 
For a transparent wall surface the absorbed power is released in the wall surface node and the 
different wall layer interface nodes according to the distribution calculated by Edwards’ 
embedding technique. 

− Chart > Wall Surface Temperature (only enabled from the Walls window): shows the wall 
surface temperature (in °C) at the current wall surface (determined by the position of the input 
cell in the Walls window, i.e. wall side 1 for column “From Zone”, “hg1”, “hc1”, and wall side 2 
for column “To Zone”, “hg2”, “hc2”). 

− Chart > Zone Temperature (only enabled from the Zones window): shows the zone air (or 
fluidum) temperature (in °C) in the current zone (determined by the position of the input cell in 
the Zones window). 
The zone temperature is either a boundary condition or the calculated temperature in the 
convection node (for a zone with separate radiation and convection). 

− Chart > Operative Temperature (only enabled from the Zones window for zones with separate 
radiation and convection): shows the operative temperature (in °C) in the current zone 
(determined by the position of the input cell in the Zones window). 
The operative temperature is the mean value of the air temperature and the radiation temperature 
(area weighted average of all surrounding wall surface temperatures). 

− Chart > Ventilation Power (only enabled from the Zones window): shows the ventilation power 
(in W) into the current zone (determined by the position of the input cell in the Zones window). 
At the bottom left of the chart appears the total ventilation energy (in kWh) during the given time 
range of the chart. 
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− Chart > Absorbed Solar Power (only enabled from the Zones window): shows the total absorbed 
solar power (in W) at the wall surfaces bordering the current zone (determined by the position of 
the input cell in the Zones window). 
This total absorbed solar power is evaluated as the sum of the solar absorption powers at all wall 
surfaces touching this zone. 
At the bottom left of the chart appears the total absorbed solar energy (in kWh) during the given 
time range of the chart. 

− Chart > Condition (only enabled from the Conditions window): shows the condition results (0 = 
false, 1 = true) of the current condition (determined by the position of the input cell in the 
Conditions window). 
At the bottom left of the chart appears the total time (in h) that the condition result is true 
compared to the total time range of the chart. 
 

 
 

− Chart > Control (only enabled from the Controls window): shows either the control result (0 = 
off, 1 = on) or the control power (if the input cell is in the column “Pmax” and the control action 
is either heating or cooling; in W) for the current control (determined by the position of the input 
cell in the Controls window). 
At the bottom left of the chart appears either the total time (in h) that the control is on compared 
to the total time range of the chart, or the total control energy (in kWh) during the given time 
range of the chart. 
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E.3. Chart time scale 

The time scale defines the range of the horizontal axis of the chart and chart ticks on it. 
The command Chart > Time Scale opens a dialog box (cf. figure below) with the following 
parameters: 
− From: calculation start (as defined in the Time window) or other user defined time. 
− To: current time, calculation end (as defined in the Time window) or other user defined time. 
− Tick unit: day in month, hour or minute. 
− Minor tick: expressed in tick units (marks without labels). 
− Major tick: expressed in tick units (multiple of minor tick and labelled). 
− Label: day in month (1-31) or hour (0-23) printed beneath major tick marks. 
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E.4. Save chart image, chart values and output filter 

The command Chart > Save Chart… allows to save the chart (as in the Chart window) into a PNG 
image file. 
The image resolution (width and height in pixels) and font size for labels are defined using the 
command Settings > Graphic Output Size… (cf. section B.12). 
 
The command Chart > Save Values… allows to save the ordinate values of the chart into a text file 
(with extension .txt). 
The output values are filtered using the parameters in the Output Filter dialog box (cf. figure 
below), opened with the command Chart > Output Filter…. 
 

 
 
The output filter parameters are: 
− Statistical function applied to each set of values (in a fixed time interval, defined by the 

frequency): 
None: no statistical function is used. 
Mean: mean value. 
Min: minimum value. 
Max: maximum value. 
Integral: sum of products of variable values and time step (time unit: h) for all time steps of 

42 Manual CAPSOL v5.0w  



Manual CAPSOL v5.0w 43 

given time interval.  E.g.: energy consumption as integral of heating power. 
Duration >: time duration (in h) in which variable values are greater than a given constant value. 
E.g.: temperature transgression duration. 

− Output frequency: 
Step: output per calculation time step. 
Hour: output per hour. 
Day: output per day. 
N days: output per given number of days. 
Week: output per 7 days. 
Month: output per calendar month. 
Year: output per 365 days. 

− Time scope 0-24 h: only variable values within the given scope are included. 
− Scope weekday (1 = Monday, 2 = Tuesday, …, 7 = Sunday): only variable values within the 

given scope are included.  January 1 (of year 0) is defined as a Monday. 



CHAPTER F WALL TYPE EDITOR 

F.1. Wall type composition 

The wall type editor is a separate program (WallTypeEdit.exe) for the definition of the layer 
composition of wall types used in CAPSOL. 
Each wall type consists of one or more layers. 
The layers are ordered from side 1 toward side 2. 
For external walls side 1 must correspond to the outside of the building, while side 2 corresponds to 
the inside. 
CAPSOL must use this wall orientation in the definition of zones at both sides of each wall in the 
Walls window (cf. remark in section B.6). 
 

 
 
There are two types of layers: 
− Normal layers, used for solid materials. 
− Gas layers, used for cavities. 

A gas layer must always be enclosed between two normal layers (because the radiative resistance 
of the gas layer is dependent on the infrared emissivities of both adjacent material layer 
surfaces). 

 
A new normal layer can be inserted using Edit Layer > Insert Before (NORMAL) or Edit Layer > 
Insert After (NORMAL). 
A new gas layer is inserted together with a normal layer using Edit Layer > Insert Before 
(GAS+NORMAL) or Edit Layer > Insert After (GAS+NORMAL). 

F.2. Properties of a normal layer 

− Name. 
− Type = NORMAL. 
− Dot pattern (not used in CAPSOL v5.0w). 
− d [m]: layer thickness 
− λ [W/(m.K)]: thermal conductivity. 
− R [m2.K/W]: thermal resistance (R = d/λ). 
− ρ [kg/m3]: density. 
− c [J/(kg.K)]: specific heat. 
− τs: solar transmission factor. 
− ε1ir: infrared emission factor of exterior layer surface (at side 1). 
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− ρ1s: solar reflection factor of exterior layer surface (at side 1). 
The solar reflection factor ρ1s of the first layer, adjacent to the exterior environment, can be 
defined in function of the angle of incidence (cf. section F.5). 

− α1s: solar absorption factor of exterior layer surface (at side 1). 
− ε2ir: infrared emission factor of interior layer surface (at side 2). 
− ρ2s: solar reflection factor of interior layer surface (at side 2). 
− α2s: solar absorption factor of interior layer surface (at side 2). 

F.3. Properties of a gas layer 

− Name. 
− Type = GAS. 
− Dot pattern (not used in CAPSOL v5.0w). 
− d [m]: layer thickness 
− λ [W/(m.K)]: thermal conductivity of the gas. 
− ρ [kg/m3]: density of the gas. 
− c [J/(kg.K)]: specific heat of the gas. 
− Nu: Nusselt number of the gas layer. 

If Nu = 1, then there is no convection and only conductive heat transfer. 

The convective resistance of the gas layer is: 
Nu

dRc ×
=

λ
. 

− hrb [W/(m2.K)]: black radiation heat transfer coefficient. 
( ) ( )jijirb TTTTh +×+×= 22σ  

with σ = 5.67 * 10-8 W/(m2.K4)  (Stefan-Boltzmann constant), 
and Ti, Tj = absolute temperatures of adjacent material layer surfaces (unit: K). 

The radiative resistance of the gas layer is: 
rb

r h
R

111

21

−+
=

εε  

with ε1, ε2 = infrared emission factors of adjacent material layer surfaces. 
 

The total thermal resistance (in the column R, not editable) of the gas layer is: 

rc RR

R 11
1

+
= . 

F.4. Material database 

Material properties can be selected from a material database using the command Edit Layer > Load 
Material. 
The Material Database dialog box allows to choose a material database (e.g. based on a national 
standard), then a group of materials, and finally a material.  The properties of the selected material 
are displayed and copied into the current layer when OK is pressed. 
The available material databases are stored in text files with extension .phm in the data folder 
..\Physibel\Materials.  The files can be edited using the program MatEdit.exe in the same folder. 
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F.5. Angular dependent solar reflection factor 

 

For external walls (e.g. glazings) between the solar zone and an internal 
zone the solar reflection at the external side can be defined in function of 
the angle of incidence. 
The solar reflection factor ρ1s of the exterior layer surface as defined in 
the first layer (cf. section F.2) is considered as reference value, valid at 
normal incidence (angle of incidence = 0°). 
The angular dependent solar reflection is defined in the dialog box 
opened with the command Edit Layer > Edit Angular Reflection using 
percentages p per angle (in steps of 15°): 

( )
100

1 11
p

ss ×−+= ρρρθ  

with ρθ = solar reflection factor for angle of incidence θ, 
and ρ1s = solar reflection factor of exterior layer surface of first layer. 
The reflection factors of intervening angles are calculated by linear 
interpolation. 
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F.6. U-value and g-value calculation 

The wall type editor calculates automatically the thermal transmittance (U-value) and total solar 
energy transmittance or solar factor (g-value).  The calculation is according to the European 
standards EN 673 and EN 410. 
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CHAPTER G PROGRAM FUNCEDIT 

G.1. Introduction 

The function editor FUNCEDIT is a separate program (Funcedit.exe) to edit and visualise function 
files for use in CAPSOL (and the other non-steady state Physibel programs VOLTRA and 
BISTRA), where these functions are used as dynamic boundary condition specifications. 
 
After starting FUNCEDIT, or creating a new function using the command File > New, a null 
temperature function of length 24 hours (with hourly values of 0°C) is displayed. 
 

 
 
An existing function file is opened with the command File > Open….  The function type can be 
chosen in the Open dialog box. 

G.2. Function types 

The following function types are used in CAPSOL: 
  unit extension use in CAPSOL 
temperature [°C] .fte boundary condition temperature 
horizontal global solar radiation [W/m2] .fsg boundary condition in solar zone 
horizontal diffuse solar radiation [W/m2] .fsd boundary condition in solar zone 
infrared radiation [W/m2] .fir boundary condition heat flux 
power [W] .ffh boundary condition power 
ventilation rate [/h] .fvr ventilation volume flow rate [m3/h] 
 
Remark 
The ventilation rate in FUNCEDIT is displayed with unit /h, but is used in CAPSOL with unit m3/h. 

G.3. Function parameters 

General header information of a function file is edited via the command Edit > Parameters. 
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A dialog box is opened with the following parameters: 
− Function type: see section G.2. 
− Comment: text description of the function. 
− Previous function and next function: file name of function that precedes the current function 

(previous function) or comes next to the current function (next function).  The previous and/or 
next function may be the same as the current function, in which case the check box “the same” is 
marked. 

− Interpolation: linear or step.  Intermediate function values are either obtained by linear 
interpolation (linear function) or remain constant during the whole time step (step function). 

− Time step [dddd:hh:mm:ss]: time interval between two successive function values in the function 
data window (cf. section G.4). 

− Total steps: number of time steps in function definition (= number of function values - 1). 
− Number of decimals: number of digits after the decimal point, for all function values in the 

function data window (cf. section G.4) and in the function file. 
− Number of columns: used in the function data window (cf. section G.4) and in the function file. 
− Day number at function start [1..365]. The “i” button gives information about the start days of 

each month. 
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− Latitude [°N], longitude [°E] and time zone [h]: geographical position of function climate 
station. 

− Chart time unit and chart time format: labelling information for the time axis in the function 
chart.  This information is not stored in the function file. 

G.4. Function data 

The function values every time step can be edited in the function data window, opened with the 
command Edit > Data.  The table format is set by the function parameters (cf. section G.3). 
 
In the left (grey) column the time corresponding to the first value in the row is given. 
A new value can be inserted using the command Edit > Insert After or the <Insert>-key.  The “total 
steps” parameter in the function parameters dialog box is incremented accordingly. 
A value can be deleted using the command Edit > Delete Value or the <Delete>-key. 
Individual table cells can be copied and pasted with Edit > Copy (or <Ctrl+C>) and Edit > Paste 
(or <Ctrl+V>). 

G.5. Graphic parameters 
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The window that is opened when a new function is created or an existing function file is read, 
contains a graphic representation of the numerical function data entered in the data window. 
The red point in the graph corresponds to the function value in the current cell of the data window. 
 
The commands in the Graphic submenu allows to edit the graph. 
 

 

 
The command Graphic > Set Scale… opens a dialog box containing scale parameters. 
The view range for both axes and tick mark distances can be set. 
 
When a rectangle is drawn in the graph, with mouse dragging holding down the left mouse button, a 
zoom rectangle is defined.  The corresponding zoom view is drawn when the left mouse button is 
released.  The initial total view (with view range as defined in the Set Scale dialog box) can be 
restored using the command Graphic > Zoom All or pressing the <Home>-key. 
 
The commands Graphic > Primary Grid X and Graphic > Primary Grid Y enable to show grid 
lines through the primary tick marks on both axes X and Y. 
 
The command Graphic > Right Axis allows to draw a vertical axis with tick marks at the right side 
of the chart border. 
 
The command Graphic > Save As Bitmap (PNG) opens a dialog box with file name and size of the 
PNG file, which is saved in the same directory as where the function file is stored. 

G.6. Using a spreadsheet program to create functions 

A function file can also be created using Microsoft Excel. 
The spreadsheet contains 6 header rows (starting with the keywords COM, PRV, NXT, TIM, FMT 
and DAT) followed by data rows with function values.  The syntax of the input data is given in the 
table below.  Save the file (as text) in the data directory, with the extension corresponding to the 
function type (cf. section G.2). 
If an existing function file, created with FUNCEDIT, has to be modified using a spreadsheet 
program, it is recommended to set the parameter “number of columns” in the Function Parameters 
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dialog box equal to 1.  Then there is only 1 column with function values in the spreadsheet (as in 
the figure below). 
 

 
 
 

row number code input data 
 column A column B column C column D column E column F 
1 COM comment     
2 PRV name of previous 

function * 
    

3 NXT name of next 
function * 

    

4 TIM interpolation: 
0 = linear / 1 = step 

time step 
(in seconds) 

total number of steps   

5 FMT total number of 
characters of the 
function values 

number of 
digits after 
decimal point 

number of columns of 
function values 

minimum 
ordinate 

maximum 
ordinate 

6 DAT date number at 
function start 

latitude longitude time zone  

7  -  ...  -  
(7 + total steps) 

function 
type** 

function 
value 

(function 
value) 

(function 
value) 

(function 
value) 

(function 
value) 

* The file extension may be omitted;  use the name *same* to specify the same previous / next function. 
** 3 letters as in file extension (cf. section G.2). 
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